dfbd07b013
PR: ports/110726 Submitted by: Eric P. Scott <eps+pbug0703@ana.com>
30 lines
735 B
Text
30 lines
735 B
Text
--- js/src/Makefile.in.orig Mon Jun 12 14:36:07 2006
|
|
+++ js/src/Makefile.in
|
|
@@ -149,7 +149,6 @@
|
|
EXPORTS += jscpucfg.h
|
|
endif
|
|
|
|
-FDLIBM_LIBRARY = fdlibm/$(LIB_PREFIX)fdm.$(LIB_SUFFIX)
|
|
JSMATH_PRELINK = jsmathtemp.o
|
|
JS_SAFE_ARENA = 1
|
|
|
|
@@ -325,9 +324,6 @@
|
|
$(LD) $(DASH_R) -o $@ $(JSMATH_PRELINK) $(FDLIBM_LIBRARY)
|
|
endif
|
|
@$(RM) -f $(JSMATH_PRELINK)
|
|
-else
|
|
-# Create dependency so we build fdlibm
|
|
-jsmath.o: $(FDLIBM_LIBRARY) Makefile.in
|
|
endif
|
|
|
|
# An AIX Optimization bug causes PR_dtoa() & JS_dtoa to produce wrong result.
|
|
--- js/Makefile.in.orig Sun Apr 18 14:57:30 2004
|
|
+++ js/Makefile.in
|
|
@@ -61,6 +61,6 @@
|
|
# See top-level makefile for details
|
|
#
|
|
|
|
-DIRS = src/fdlibm src
|
|
+DIRS = src
|
|
|
|
include $(topsrcdir)/config/rules.mk
|