freebsd-ports/lang/caml-light/files/patch-contrib_libnum_Makefile
Joseph Koshy 02e454d15d - Honor CC, CFLAGS etc. [1]
- Use BSD_INSTALL_* macros to install files.	[1]
- Make the port PREFIX clean.

PR:		ports/101398	[1]
Submitted by:	Stanislav Sedov <ssedov@mbsd.msk.ru>
2006-08-06 10:53:54 +00:00

34 lines
1 KiB
Text

--- ./contrib/libnum/Makefile-- Thu Dec 24 00:36:56 1998
+++ ./contrib/libnum/Makefile Sun Aug 6 11:40:07 2006
@@ -12,12 +12,12 @@
RANLIB=ranlib
# Compilation options
-CFLAGS=-O -I../../src/runtime -I./bignum/h
-CAMLC=camlc
+CFLAGS+=-I../../src/runtime -I./bignum/h
+CAMLC=${PREFIX}/bin/camlc
CAMLCOMP=$(CAMLC) -c
COMPFLAGS=-W #-O fast
-CAMLLIBR=camllibr
-CAMLMKTOP=camlmktop
+CAMLLIBR=${PREFIX}/bin/camllibr
+CAMLMKTOP=${PREFIX}/bin/camlmktop
ZOFILES=int_misc.zo fnat.zo nat.zo big_int.zo arith_flags.zo ratio.zo \
num.zo arith_status.zo
@@ -43,10 +43,10 @@
cd bignum; make $(BIGNUM_ARCH) CC="$(CC)"
install:
- cp libnums.a $(LIBDIR)/libnums.a
- if $(RANLIBTEST); then cd $(LIBDIR); $(RANLIB) libnums.a; else true; fi
- cp nums.zo $(ZIFILES) $(LIBDIR)
- cp camlnum $(LIBDIR)
+ ${BSD_INSTALL_DATA} libnums.a $(LIBDIR)
+ if $(RANLIBTEST); then (cd $(LIBDIR); $(RANLIB) libnums.a); else true; fi
+ ${BSD_INSTALL_DATA} nums.zo $(ZIFILES) $(LIBDIR)
+ ${BSD_INSTALL_SCRIPT} camlnum $(LIBDIR)
clean:
rm -f libnums.a *.o *.z[io] camlnum