freebsd-ports/devel/cocktail/files/patch-puma-m2c-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

79 lines
1.8 KiB
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./puma/m2c/Makefile Tue Feb 15 14:25:55 1994
+++ ./puma/m2c/Makefile Thu Aug 5 18:49:29 2004
@@ -1,39 +1,32 @@
-BIN = $(HOME)/bin
-LIB = $(HOME)/lib
-OPT = -O
-CC = cc
- # C library (reuse)
-REUSE = ../../reuse/m2c
-
- # C libraries
-CLIBS = $(REUSE)/libreuse.a
-
- # options for C compiler
-CFLAGS = -w -I$(REUSE) $(OPT)
-
-M2FLAGS = -c -d$(HOME)/reuse/src
+.include "../../Makefile.inc"
+ROOTDIR = ../..
+CFLAGS += -I$(INCDIR)
+CLIBS += $(REUSELIB)
all : puma
-install: puma puma.sh $(LIB)/puma
- if test $(LIB) = $(BIN); then echo error: BIN = LIB; false; else true; fi
- sed 's;LIB;$(LIB);g' < puma.sh > $(BIN)/puma
- chmod a+rx $(BIN)/puma
- install -c -s -m 755 puma $(LIB)/puma
- install -c -m 644 TypeTab.c $(LIB)/puma
- install -c -m 644 TypeTab.m $(LIB)/puma
+install: puma puma.sh $(DESTLIB)/puma
+ if test $(DESTLIB) = $(DESTBIN); then echo error: BIN = LIB; false; else true; fi
+ sed 's;LIB;$(DESTLIB);g' < puma.sh > $(DESTBIN)/puma
+ chmod a+rx $(DESTBIN)/puma
+ install -c -s -m 755 puma $(DESTLIB)/puma
+ install -c -m 644 TypeTab.c $(DESTLIB)/puma
+ install -c -m 644 TypeTab.m $(DESTLIB)/puma
# installation directories
-$(LIB)/puma: $(LIB)
- sh -c "if test ! -d $(LIB)/puma; then mkdir -p $(LIB)/puma; else true; fi"
+$(DESTLIB)/puma: $(DESTLIB)
+ sh -c "if test ! -d $(DESTLIB)/puma; then mkdir -p $(DESTLIB)/puma; else true; fi"
-# SYSTEM_ = SYSTEM_.o
+clean:
+ -rm -f $(STDCLEAN)
+ -rm -f *.o
+ -rm -f puma
lint:
- lint -I$(REUSE) *.c
+ lint -I$(INCDIR) *.c
# HEAD
@@ -140,18 +133,3 @@
Parser.o \
$(CLIBS)
-# TAIL
-
-clean :
- rm -f core *.o
-
-.SUFFIXES: .md .mi .h .c .o
-
-.mi.c:
- mtc2 $(M2FLAGS) $*.mi;
-
-.md.h:
- mtc2 $(M2FLAGS) $*.md;
-
-.c.o:
- $(CC) $(CFLAGS) -c $*.c