freebsd-ports/math/sundials/files/patch-src_cvodes_CMakeLists.txt
Yuri Victorovich 2a3f43cb6b New port: math/sundials: SUite of Nonlinear and DIfferential/ALgebraic Equation Solvers
This port was originally created by Pedro Giffuni. He offered me to take over it.
I updated it to 3.1.0, added many options, etc.

The option FCMIX is broken upstream, so it is not present in the port.

Approved by:	adamw (mentor)
Differential Revision:	https://reviews.freebsd.org/D13647
2017-12-27 07:47:30 +00:00

21 lines
652 B
Text

--- src/cvodes/CMakeLists.txt.orig 2017-11-07 23:48:01 UTC
+++ src/cvodes/CMakeLists.txt
@@ -116,6 +116,18 @@ IF(BUILD_SHARED_LIBS)
TARGET_LINK_LIBRARIES(sundials_cvodes_shared m)
ENDIF()
+ IF(UNIX)
+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared m)
+ ENDIF()
+
+ IF(LAPACK_FOUND)
+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared ${LAPACK_LIBRARIES})
+ ENDIF()
+
+ IF(KLU_FOUND)
+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared ${KLU_LIBRARIES})
+ ENDIF()
+
# Set the library name and make sure it is not deleted
SET_TARGET_PROPERTIES(sundials_cvodes_shared
PROPERTIES OUTPUT_NAME sundials_cvodes CLEAN_DIRECT_OUTPUT 1)