freebsd-ports/biology/kallisto/files/patch-src_CMakeLists.txt
Jason W. Bacon c9bd01bdf4 biology/kallisto: Update to 0.48.0
Fixes segfault with --genomebam in 0.46.2
Unbundle htslib
A few new features and performance improvements

Changes:        https://github.com/pachterlab/kallisto/tags
2022-01-19 07:57:36 -06:00

26 lines
836 B
Text

--- src/CMakeLists.txt.orig 2021-11-24 14:45:50 UTC
+++ src/CMakeLists.txt
@@ -3,15 +3,13 @@ file(GLOB headers *.h *.hpp)
list(REMOVE_ITEM sources main.cpp)
-include_directories(../ext/htslib)
-
add_library(kallisto_core ${sources} ${headers})
target_include_directories(kallisto_core PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
add_executable(kallisto main.cpp)
find_package( Threads REQUIRED )
-target_link_libraries(kallisto kallisto_core pthread ${CMAKE_CURRENT_SOURCE_DIR}/../ext/htslib/libhts.a)
+target_link_libraries(kallisto kallisto_core pthread)
if(LINK MATCHES static)
set(BUILD_SHARED_LIBS OFF)
@@ -56,4 +54,4 @@ else()
endif(LINK MATCHES static)
-install(TARGETS kallisto DESTINATION "${CMAKE_INSTALL_BINDIR}")
\ No newline at end of file
+install(TARGETS kallisto DESTINATION "${CMAKE_INSTALL_BINDIR}")