bfcc6c1858
- Use USERS and GROUPS.
30 lines
1.1 KiB
Text
30 lines
1.1 KiB
Text
Index: bgpctl/Makefile
|
|
===================================================================
|
|
RCS file: /home/cvs/private/hrs/openbgpd/bgpctl/Makefile,v
|
|
retrieving revision 1.1.1.1
|
|
retrieving revision 1.3
|
|
diff -u -p -r1.1.1.1 -r1.3
|
|
--- bgpctl/Makefile 30 Jun 2009 05:46:15 -0000 1.1.1.1
|
|
+++ bgpctl/Makefile 2 Jul 2011 16:06:35 -0000 1.3
|
|
@@ -1,17 +1,18 @@
|
|
# $OpenBSD: Makefile,v 1.10 2007/12/20 17:08:48 henning Exp $
|
|
|
|
-.PATH: ${.CURDIR}/../bgpd
|
|
+.PATH: ${.CURDIR}/../bgpd ${.CURDIR}/../openbsd-compat
|
|
|
|
PROG= bgpctl
|
|
-SRCS= bgpctl.c parser.c buffer.c imsg.c util.c timer.c
|
|
+SRCS= bgpctl.c parser.c util.c timer.c
|
|
SRCS+= irrfilter.c whois.c irr_asset.c irr_prefix.c irr_output.c
|
|
SRCS+= irr_parser.c
|
|
+SRCS+= fmt_scaled.c imsg.c imsg-buffer.c
|
|
CFLAGS+= -Wall
|
|
CFLAGS+= -Wstrict-prototypes -Wmissing-prototypes
|
|
CFLAGS+= -Wmissing-declarations
|
|
CFLAGS+= -Wshadow -Wpointer-arith -Wcast-qual
|
|
CFLAGS+= -Wsign-compare
|
|
-CFLAGS+= -I${.CURDIR} -I${.CURDIR}/../bgpd
|
|
+CFLAGS+= -I${.CURDIR} -I${.CURDIR}/../bgpd -I${.CURDIR}/../openbsd-compat
|
|
MAN= bgpctl.8
|
|
LDADD= -lutil
|
|
DPADD+= ${LIBUTIL}
|