o Update URL in MASTER_SITES to current address o Update MAINTAINER o Remove post-patch target as it is not needed - Use LDFLAGS instead of the non-standard variable ADDITIONALLINKOPTIONS. - Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate patch files as the command triggers multiple warnings. log2 is a macro defined in src/log.h. The name of this macro is in conflict with the function log2 from math.h. To avoid errors when compiling the code, the above renaming is necessary. Furthermore, PHB 4.4.3 strongly suggests using patch files instead of REINPLACE_CMD for static content. o Sort pkg-plist alphabetically as required by PHB 3.2.2 o Shorten pkg-descr and make it less technical PR: 250879 Submitted by: Moritz Schmitt (maintainer)
16 lines
698 B
C++
16 lines
698 B
C++
--- src/gfanlib_zfan.cpp.orig 2017-06-20 14:47:37 UTC
|
|
+++ src/gfanlib_zfan.cpp
|
|
@@ -162,11 +162,11 @@ namespace gfan
|
|
|
|
ZFan ret(sym);
|
|
|
|
-// log2 cerr<< "Number of orbits to expand "<<cones.size()<<endl;
|
|
+// gfan_log2 cerr<< "Number of orbits to expand "<<cones.size()<<endl;
|
|
for(unsigned i=0;i<cones.size();i++)
|
|
// if(coneIndices==0 || coneIndices->count(i))
|
|
{
|
|
-// log2 cerr<<"Expanding symmetries of cone"<<endl;
|
|
+// gfan_log2 cerr<<"Expanding symmetries of cone"<<endl;
|
|
{
|
|
ZMatrix coneRays(0,n);
|
|
for(list<int>::const_iterator j=cones[i].begin();j!=cones[i].end();j++)
|