o Update URL in MASTER_SITES to current address o Update MAINTAINER o Remove post-patch target as it is not needed - Use LDFLAGS instead of the non-standard variable ADDITIONALLINKOPTIONS. - Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate patch files as the command triggers multiple warnings. log2 is a macro defined in src/log.h. The name of this macro is in conflict with the function log2 from math.h. To avoid errors when compiling the code, the above renaming is necessary. Furthermore, PHB 4.4.3 strongly suggests using patch files instead of REINPLACE_CMD for static content. o Sort pkg-plist alphabetically as required by PHB 3.2.2 o Shorten pkg-descr and make it less technical PR: 250879 Submitted by: Moritz Schmitt (maintainer)
28 lines
1.3 KiB
C++
28 lines
1.3 KiB
C++
--- src/padic.cpp.orig 2017-06-20 14:47:37 UTC
|
|
+++ src/padic.cpp
|
|
@@ -406,14 +406,14 @@ void pAdicBuchberger(PolynomialSet &g, int prime, Inte
|
|
for(PolynomialSet::const_iterator i=g.begin();i!=g.end();i++)
|
|
for(PolynomialSet::const_iterator j=g.begin();j!=i;j++)
|
|
{
|
|
-log2 debug<<"checking s poly\n"<<*i<<"("<<ST(*i,prime,omega,tieBreaker)<<")"<<"\n"<<*j<<"("<<ST(*j,prime,omega,tieBreaker)<<")"<<"\n";
|
|
+gfan_log2 debug<<"checking s poly\n"<<*i<<"("<<ST(*i,prime,omega,tieBreaker)<<")"<<"\n"<<*j<<"("<<ST(*j,prime,omega,tieBreaker)<<")"<<"\n";
|
|
Polynomial f=SPolynomial(*i,*j,prime,omega,tieBreaker);
|
|
// debug<<"S="<<f<<"\n";
|
|
// Enable the relatively prime criterion by uncommenting this following:
|
|
#if 1
|
|
if(relativelyPrime(ST(*i,prime,omega,tieBreaker).m.exponent,ST(*j,prime,omega,tieBreaker).m.exponent))
|
|
{
|
|
-log2 debug<<"SKIPPING\n";
|
|
+gfan_log2 debug<<"SKIPPING\n";
|
|
}
|
|
else
|
|
#endif
|
|
@@ -424,7 +424,7 @@ log2 debug<<"SKIPPING\n";
|
|
f=longDivision(f,g,prime,omega,tieBreaker,H,u);
|
|
if(!f.isZero())
|
|
{
|
|
-log2 debug<<"Adding:"<<f<<"\n";
|
|
+gfan_log2 debug<<"Adding:"<<f<<"\n";
|
|
g.push_back(f);
|
|
}
|
|
}
|