freebsd-ports/www/mozilla/files/patch-gfx-src-gtk-Makefile.in
Michael Johnson 36353c589f - Update firefox to 1.5
- Add Makefile.common
  o A new build/install system for gecko ports, Makefile.common
    includes many generic routines and common tasks.
  o Fix ld-run-path in all gecko's by using -Wl,-rpath,${moz_libdir}
    thus removing the need to have a startup script for ports that
    depend on gecko. [2]
  o Use system libm, nss, nspr in all gecko ports

- Add bsd.gecko.mk
  o This is the predecessor to WITH_MOZILLA=[mozilla|firefox|...]
    with a more robust way of detecting a gecko a end user wishs to
    use.
  o bsd.gecko.mk abstracts the selection of gecko-based backends. It
    allows users and porters to support any available gecko backend
    without needing to build many conditional tests. ${USE_GECKO} is the
    list of backends that your port can handle, and ${GECKO} is set by
    bsd.gecko.mk to be the chosen backend. Users set ${WITH_GECKO} to the
    list of gecko backends they want on their system.

  Port Makefile example:

  USE_GECKO=firefox mozilla seamonkey thunderbird
  .include <bsd.port.pre.mk>
  .include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"

  End user example:
  WITH_GECKO=seamonkey firefox

  We highly recommend moving away from using WITH_MOZILLA and switching to
  USE/WITH_GECKO.

PR:		89052 [2]
Submitted by:	vs [2]
Obtained from:	www/firefox
Thanks to:	adamw, marcus, and mezz for ideas, bug squashing, and more
		sajd from irc.freenode.org/#FreeBSD-Gnome for
		 pointing out many bugs
2005-11-29 21:12:28 +00:00

15 lines
459 B
Text

When using ``--with-system-nspr'' option, MOZ_COMPONENT_LIBS does not
contain the ``-L../../../dist/lib'' -- only ``-L../../../dist/bin''.
This causes an error, because libgfxshared_s is only under dist/lib.
-mi
--- gfx/src/gtk/Makefile.in Mon Nov 10 07:24:51 2003
+++ gfx/src/gtk/Makefile.in Thu Jul 21 23:58:26 2005
@@ -165,4 +165,5 @@
ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_COMPONENT_LIBS) \
+ $(LIBS_DIR) \
-lgkgfx \
-lgfxshared_s \