freebsd-ports/lang/gcc44/files/java-patch-hier
Gerald Pfeifer 8865a0da82 Update to the 20050730 snapshot of GCC 4.1.0.
Replace the WITHOUT_LIBJAVA knob by WITHOUT_JAVA which also disables
building the compiler and tools proper and avoids fetching the entire
Java frontend and library tarball.

Remove bogus ${PREFIX}/share/classpath/api directory that libjava adds
these days.

Make the (optional) handling of the Fortran and Java frontends easier
to understand.
2005-08-01 19:02:03 +00:00

16 lines
658 B
Text

Index: libjava/Makefile.in
===================================================================
RCS file: /cvs/gcc/gcc/libjava/Makefile.in,v
retrieving revision 1.522
diff -u -3 -p -r1.522 Makefile.in
--- libjava/Makefile.in 19 May 2005 21:46:39 -0000 1.522
+++ libjava/Makefile.in 29 May 2005 16:00:44 -0000
@@ -696,7 +696,7 @@ toolexeclib_LTLIBRARIES = libgcj.la libg
$(cond_gtk_ltlibrary) $(cond_gtk_gcjawt_ltlibrary) $(cond_xlib_ltlibrary)
toolexecmainlib_DATA = libgcj.spec
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = libgcj.pc
jardir = $(datadir)/java
jar_DATA = libgcj-$(gcc_version).jar