freebsd-ports/math/scilab/files/patch-clang
Max Brazhnikov 57a37508d6 math/scilab:
- Update to 5.5.0
- Populate USES with desktop-file-utils, iconv, libtool, pathfix,
  and shared-mime-info
- Add dependency on xdg-utils
- Remove needless USE_LDCONFIG
- Clean up CONFIGURE_ENV from stale stuff
- Update options:
  . remove DOCS, FFTW, MATIO, UMFPACK (always build with them for simplicity)
  . remove NLS (doesn't build without it)
  . merge HELP with GUI
  . PVM is not supported anymore
  . Enable OCAML and TK by default
- Use options heplers
- Clean up post-patch section from stale fixes
- Convert to static pkg-plist
2014-09-04 18:20:53 +00:00

19 lines
479 B
Text

--- modules/core/includes/core_math.h.orig 2014-04-11 09:51:38.000000000 +0000
+++ modules/core/includes/core_math.h 2014-07-23 08:27:27.143519955 +0000
@@ -53,11 +53,11 @@
#define DEG2RAD(x) ((x) * PI_OVER_180 )
#define RAD2DEG(x) ((x) * _180_OVER_PI )
-#ifdef round
-#undef round
-#endif
-
-#define round(a) (int)(((a)<0.0)?(a)-.5:(a)+.5)
+// #ifdef round
+// #undef round
+// #endif
+//
+// #define round(a) (int)(((a)<0.0)?(a)-.5:(a)+.5)
#define EPSILON 1.0e-13