freebsd-ports/x11/xscreensaver/files/patch-driver_Makefile.in
Niclas Zeising 3741caa42d A bunch of cleanups and fixes.
Fix build with compiler is gccXX (where xx is for instance 46, 47) by
running autoconf to generate a working configure.
Use ${REINPLACE_CMD} instead of hand-rolled sed.  Change regexp to work on
configure.in instead of configure, since we'll autoconf configure.in anyway.
Check for libutil.h alongside util.h, and make use of that if it is found.
Make detection and use of gettext work with all compilers.  Add locale
messages to plist.
Bump portrevision.

Noticed by:	avg (build issues)
Tested by:	avg
2013-09-02 12:05:58 +00:00

22 lines
660 B
Text

--- driver/Makefile.in.orig 2013-07-16 11:23:32.000000000 +0200
+++ driver/Makefile.in 2013-09-02 11:56:16.862939343 +0200
@@ -81,8 +81,8 @@
AD_DIR = @APPDEFAULTS@
-PAM_DIR = /etc/pam.d
-PAM_CONF = /etc/pam.conf
+PAM_DIR = ${prefix}/etc/pam.d
+PAM_CONF = ${prefix}/etc/pam.conf
UTILS_SRC = $(srcdir)/../utils
UTILS_BIN = ../utils
@@ -207,7 +207,7 @@
SAVER_LIBS = $(LIBS) $(X_LIBS) $(XMU_LIBS) @SAVER_LIBS@ \
$(XDPMS_LIBS) $(XINERAMA_LIBS) $(GL_LIBS) $(X_PRE_LIBS) \
-lXt -lX11 -lXext $(X_EXTRA_LIBS) \
- $(PASSWD_LIBS)
+ $(PASSWD_LIBS) $(INTL_LIBS)
CMD_LIBS = $(LIBS) $(X_LIBS) \
$(X_PRE_LIBS) -lX11 -lXext $(X_EXTRA_LIBS)