freebsd-ports/x11/xscreensaver/files/patch-utils_textclient.c
Niclas Zeising 3741caa42d A bunch of cleanups and fixes.
Fix build with compiler is gccXX (where xx is for instance 46, 47) by
running autoconf to generate a working configure.
Use ${REINPLACE_CMD} instead of hand-rolled sed.  Change regexp to work on
configure.in instead of configure, since we'll autoconf configure.in anyway.
Check for libutil.h alongside util.h, and make use of that if it is found.
Make detection and use of gettext work with all compilers.  Add locale
messages to plist.
Bump portrevision.

Noticed by:	avg (build issues)
Tested by:	avg
2013-09-02 12:05:58 +00:00

12 lines
297 B
C

--- utils/textclient.c.orig 2013-09-02 12:43:01.271738814 +0200
+++ utils/textclient.c 2013-09-02 12:43:25.014748042 +0200
@@ -50,6 +50,9 @@
# ifdef HAVE_UTIL_H
# include <util.h>
# endif
+# ifdef HAVE_LIBUTIL_H
+# include <libutil.h>
+# endif
#endif /* HAVE_FORKPTY */
/*#define DEBUG*/