6c10d7297f
- remove indefinite article from COMMENT - add license (BSD3C) - do not use easy_install for installation and convert to auto-generated packing list - add staging support - simplify docs installation: - install docs manually - install docs unconditionally into staging area - no need to install doc sources, compiled html versions are suffice - limit python version to 2.x only: ===> Configuring for py33-Jinja-1.2_3 Traceback (most recent call last): File "<string>", line 1, in <module> File "setup.py", line 28 except DistutilsError, e: ^ SyntaxError: invalid syntax *** Error code 1 - remove deprecated author attribution from pkg-descr and do tab->space change in WWW - bump PORTREVISION Approved by: nivit (maintainer, explicitly for such changes in his ports)
14 lines
472 B
Python
14 lines
472 B
Python
--- ./setup.py.orig 2007-11-17 20:13:24.000000000 +0300
|
|
+++ ./setup.py 2014-03-03 13:21:43.000000000 +0400
|
|
@@ -78,10 +78,7 @@
|
|
],
|
|
keywords=['python.templating.engines'],
|
|
packages=['jinja', 'jinja.translators'],
|
|
- data_files=[
|
|
- ('docs/html', list(list_files('docs/html'))),
|
|
- ('docs/txt', list(list_files('docs/src')))
|
|
- ],
|
|
+ data_files=[],
|
|
entry_points='''
|
|
[python.templating.engines]
|
|
jinja = jinja.plugin:BuffetPlugin
|