freebsd-ports/mail/imap-uw/files/patch-af
Kelly Yancey 4e4ffa22f2 Update imap-uw to depend on the cclient port.
The mail/imap-uw port used to build a shared library version of cclient
of it's own (in fact, this is where much of the infrastructure for the
cclient port came from). However, since more things depend on cclient
then just UW's imap server, I broke them into separate ports.

From now on, nothing should have to depend on imap-uw just to get
c-client.

PR:		19749
Submitted by:	kbyanc@posi.net
2000-07-17 08:47:13 +00:00

37 lines
805 B
Text

--- src/ipopd/Makefile.orig Tue Apr 14 15:41:55 1998
+++ src/ipopd/Makefile Fri Jul 7 00:27:30 2000
@@ -32,29 +32,22 @@
C = ../c-client
-CCLIENTLIB = $C/c-client.a
+#CCLIENTLIB = $C/c-client.a
SHELL = /bin/sh
# Get local definitions from c-client directory
CC = `cat $C/CCTYPE`
-CFLAGS = -I$C `cat $C/CFLAGS`
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+CFLAGS = `cat $C/CFLAGS`
+LDFLAGS = `cat $C/LDFLAGS`
ipopd: ipop2d ipop3d
-ipop2d: $(CCLIENTLIB) ipop2d.o
+ipop2d: ipop2d.o
$(CC) $(CFLAGS) -o ipop2d ipop2d.o $(LDFLAGS)
-ipop3d: $(CCLIENTLIB) ipop3d.o
+ipop3d: ipop3d.o
$(CC) $(CFLAGS) -o ipop3d ipop3d.o $(LDFLAGS)
-
-ipop2d.o: $C/mail.h $C/misc.h $C/osdep.h
-
-ipop3d.o: $C/mail.h $C/misc.h $C/osdep.h
-
-$(CCLIENTLIB):
- cd $C;make
clean:
rm -f *.o ipop2d ipop3d || true