freebsd-ports/sysutils/powerman/files/patch-test-Makefile
Greg Lewis 3b06cdd620 Add a port of PowerMan:
PowerMan is a tool for manipulating remote power control (RPC)
devices from a central location. Several RPC varieties are supported
natively by PowerMan and Expect-like configurability simplifies the
addition of new devices.

WWW: http://www.llnl.gov/linux/powerman/
2004-06-17 16:14:13 +00:00

20 lines
486 B
Text

$FreeBSD$
--- test/Makefile.orig Mon Dec 8 20:30:52 2003
+++ test/Makefile Tue Mar 30 10:19:02 2004
@@ -1,10 +1,13 @@
-CFLAGS= -g -Wall -I../src
+#CFLAGS= -g -Wall -I../src
+CFLAGS+= -Wall -I../src
VICEOBJS = vicebox.o wrappers.o error.o debug.o
all: vpcd
vpcd: vpcd.o
- $(CC) -o $@ $< -lpthread
+ $(CC) -o $@ $< ${LDFLAGS} ${PTHREAD_LIBS}
+vpcd.o: vpcd.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) ${PTHREAD_CFLAGS} -c -o $@ $<
vicebox : $(VICEOBJS)
$(CC) $(CFLAGS) -o $@ $(VICEOBJS)