freebsd-ports/x11/nvidia-driver/files/extra-patch-src-Makefile
Marius Strobl b4449fb54a Fix two issues with r354638:
- Use MACHINE_CPUARCH rather than MACHINE_ARCH. While the former technically
  is more correct it unfortunately doesn't exist in stable/8, yet, and using
  the latter actually doesn't make a difference for i386.
- Allow to build nvidia-driver on OSVERSION > 1000052 with the LINUX option
  enabled.

Reported by:	swills
2014-05-21 10:32:46 +00:00

18 lines
443 B
Text

--- src/Makefile.orig 2014-04-04 23:24:59.000000000 +0200
+++ src/Makefile 2014-05-06 14:31:07.000000000 +0200
@@ -24,6 +24,15 @@
stdarg.h:
@ln -s machine/stdarg.h stdarg.h
+SRCS+= opt_global.h
+.if ${MACHINE_ARCH} == "i386" && !defined(KERNBUILDDIR)
+PAE!= sed -n '/define NV_SUPPORT_PAE/p' nv-freebsd.h
+.if !empty(PAE)
+opt_global.h:
+ echo "#define PAE 1" > ${.TARGET}
+.endif
+.endif
+
*.c: stdarg.h
beforeinstall: ${KMOD}.ko