b39aab511c
Release Notes: http://mozilla.com/thunderbird/2.0.0.0/releasenotes/
24 lines
565 B
Makefile
24 lines
565 B
Makefile
--- security/coreconf/FreeBSD.mk.orig Mon Sep 25 18:26:23 2006
|
|
+++ security/coreconf/FreeBSD.mk Mon Sep 25 18:27:03 2006
|
|
@@ -45,8 +45,12 @@
|
|
ifeq ($(OS_TEST),alpha)
|
|
CPU_ARCH = alpha
|
|
else
|
|
+ifeq ($(OS_TEST),amd64)
|
|
+CPU_ARCH = amd64
|
|
+else
|
|
CPU_ARCH = x86
|
|
endif
|
|
+endif
|
|
|
|
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
|
|
|
@@ -73,7 +77,7 @@
|
|
DLL_SUFFIX = so.1.0
|
|
endif
|
|
|
|
-MKSHLIB = $(CC) $(DSO_LDOPTS)
|
|
+MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS) -o $@
|
|
ifdef MAPFILE
|
|
MKSHLIB += -Wl,--version-script,$(MAPFILE)
|
|
endif
|