64b2589784
- adding a build dependency on v4l_compat; - fixing the paths to locate videodev.h in configure.in, and disabling the (incorrect) check for V4L2; - correct the paths in grabber-video4linux.cpp, and also add support for the read() method in addition to mmap. On the mailing list there was a suggestion to remove the hardwired path in favour of a variable ( %%LOCALBASE%% or so) based one. But this configure.in is full of hardwired paths, so fixing one doesn't help at all, and the full fix would take more time and knowledge that i have.
33 lines
1.2 KiB
Text
33 lines
1.2 KiB
Text
--- configure.in.orig Thu Jul 10 16:55:43 2003
|
|
+++ configure.in Mon Feb 12 17:58:29 2007
|
|
@@ -69,18 +69,11 @@
|
|
if test -r /usr/include/machine/ioctl_meteor.h ; then
|
|
V_OBJ_GRABBER="video/grabber-meteor.o $V_OBJ_GRABBER"
|
|
fi
|
|
-if test -r /usr/include/linux/videodev.h ; then
|
|
- if grep V4L2 /usr/include/linux/videodev.h >/dev/null 2>&1 ; then
|
|
- V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-v4l2.o"
|
|
- else
|
|
- V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-video4linux.o"
|
|
- fi
|
|
-fi
|
|
-#if test -r /usr/local/lib/libspigot.a -a ${PORTOBJFORMAT} != elf; then
|
|
-if test -r /usr/local/lib/libspigot.a ; then
|
|
- V_OBJ_GRABBER="video/grabber-spigot.o $V_OBJ_GRABBER"
|
|
- V_LIB_GRABBER="$V_LIB_GRABBER -lspigot"
|
|
+if test -r /usr/local/include/linux/videodev.h ; then
|
|
V_INCLUDE_GRABBER="$V_INCLUDE_GRABBER -I/usr/local/include"
|
|
+ V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-video4linux.o"
|
|
+ # no V4L2 support yet.
|
|
+ # V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-v4l2.o"
|
|
fi
|
|
if test "$qcamdir" != "" ; then
|
|
V_OBJ_GRABBER="video/grabber-qcam.o $V_OBJ_GRABBER"
|
|
@@ -254,6 +247,7 @@
|
|
else
|
|
V_DEFINE="$V_DEFINE -DFreeBSD"
|
|
fi
|
|
+ V_DEFINE="$V_DEFINE -DSIGARGS=int"
|
|
OPSYS=freebsd
|
|
;;
|
|
*-*-hpux*)
|