freebsd-ports/math/glucose/files/patch-mtl_template.mk
Yuri Victorovich eb924c41bc New port: math/glucose: Parallel SAT solver based on Minisat, with glue clauses
See the full description here:
http://www.labri.fr/perso/lsimon/glucose/

Patches and build warnings were reported to the authors.

Submitted by:	myself
Approved by:	adamw (mentor)
Differential Revision:	https://reviews.freebsd.org/D14156
2018-02-03 20:59:14 +00:00

13 lines
366 B
Makefile

--- mtl/template.mk.orig 2018-02-03 20:34:58 UTC
+++ mtl/template.mk
@@ -18,8 +18,8 @@ DCOBJS = $(addsuffix d, $(COBJS))
RCOBJS = $(addsuffix r, $(COBJS))
CXX ?= g++
-CFLAGS ?= -Wall -Wno-parentheses -std=c++11
-LFLAGS ?= -Wall -lpthread
+CFLAGS += -Wall -Wno-parentheses -std=c++11
+LFLAGS += -Wall -lpthread
COPTIMIZE ?= -O3