freebsd-ports/japanese/nethack32/files/patch-ad

40 lines
1.2 KiB
Text

diff -ruN ./sys/unix/Makefile.top ../nethack-3.2.2/sys/unix/Makefile.top
--- ./sys/unix/Makefile.top Wed Dec 11 05:20:10 1996
+++ ../nethack-3.2.2/sys/unix/Makefile.top Sun Nov 22 00:26:55 1998
@@ -16,14 +16,14 @@
# make NetHack
GAME = nethack
GAMEUID = games
-GAMEGRP = bin
+GAMEGRP = games
# Permissions - some places use setgid instead of setuid, for instance
# See also the option "SECURE" in include/config.h
-GAMEPERM = 04755
-FILEPERM = 0644
+GAMEPERM = 02755
+FILEPERM = 0664
EXEPERM = 0755
-DIRPERM = 0755
+DIRPERM = 0775
# GAMEDIR also appears in config.h as "HACKDIR".
#
@@ -32,13 +32,13 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
# instructions)
-GAMEDIR = /usr/games/lib/$(GAME)dir
-SHELLDIR = /usr/games
+GAMEDIR = ${PREFIX}/lib/$(GAME)dir
+SHELLDIR = ${PREFIX}/bin
# per discussion in Install.X11
-VARDATND =
+# VARDATND =
# VARDATND = x11tiles pet_mark.xbm
-# VARDATND = x11tiles pet_mark.xbm rip.xpm
+VARDATND = x11tiles pet_mark.xbm rip.xpm
VARDATD = data oracles options quest.dat rumors
VARDAT = $(VARDATD) $(VARDATND)