1e34739b64
Setuptools is the preferred method to manage Python distributions after many changes to the packaging ecosystem over the past couple of years. Only ports using USE_PYDISTUTILS= yes are affected by this commit, ports using USE_PYDISTUTILS= easy_install remains the same however this usage is now deprecated and should be converted to USE_PYDISTUTILS= yes. Some Python distributions do not work with setuptools out of the box because they extend the install command from distutils and not setuptools, and so they need to be patched accordingly. pip (which leverages setuptools) works around the issue by using eggs, however we want to get rid of those as well, as support for "flat" installation is unavailable or has other issues associated with it. This work allows us to unify how python packages are built, ensure that Python distributions are installed consistently, reduces complexity for Python port maintainers and paves the way for simplifying the Python ports framework in the future. With hat on: python Reviewed by: koobs, antoine Exp-run: bdrewery Approved by: bdrewery (portmgr)
15 lines
655 B
Python
15 lines
655 B
Python
--- setup.py.orig 2013-12-13 13:00:13.747424982 -0200
|
|
+++ setup.py 2013-12-13 13:01:10.453423405 -0200
|
|
@@ -27,9 +27,9 @@
|
|
from distutils.dist import Distribution
|
|
from distutils.core import setup
|
|
from distutils.command.build import build
|
|
-from distutils.command.build_py import build_py
|
|
-from distutils.command.install import install
|
|
-from distutils.command.install_scripts import install_scripts
|
|
+from setuptools.command.build_py import build_py
|
|
+from setuptools.command.install import install
|
|
+from setuptools.command.install_scripts import install_scripts
|
|
from distutils.command.install_data import install_data
|
|
from distutils.core import Command
|
|
|