Highlights: - New Roslyn compiler for C# available - Improved support for nuget packages in USES=mono General: - fix pkg-plist: mono now produces '.pdb' debug files instead of '.mdb' - bump all dependant ports USES=mono: - properly handle caching of nuget packages - add support for multiple feeds for nuget packages - add support for nuget dependencies in a separate file - add support for paket packages lang/mono: - update to version 5.2.0.215 - automate certificate initialisation [2] - increase test coverage - mark as conflicting with net/czmq (conflicting on makecert) [1] - patch mono to use $PREFIX/share/mono instead of /usr/share/.mono devel/google-gdata: - use nunit.framework nuget package as the Mono shipped version is no longer suppport. - switch to using csc(1) for compiling (mcs(1) is depreciated). - use delayed signing (and then sign with sn(1)) as csc(1) does not support signing. - fix reference to system assemblies (the '.dll' suffix is required). - fix reference to HttpUtility: csc(1) is more strict about scoping devel/monodevelop: - reroll distinfo (no changes to content) lang/fsharp: - reroll distinfo (no changes to content) security/gnome-keyring-sharp: - delay sign (then sign with sn(1)) as csc(1) does not support direct signing. PR: 223188 [1] PR: 209670 [2] Differential Revision: https://reviews.freebsd.org/D13752
11 lines
586 B
C#
11 lines
586 B
C#
--- mcs/class/Mono.Security/Mono.Security.Cryptography/KeyPairPersistence.cs.orig 2017-07-20 18:10:59 UTC
|
|
+++ mcs/class/Mono.Security/Mono.Security.Cryptography/KeyPairPersistence.cs
|
|
@@ -244,7 +244,7 @@ namespace Mono.Security.Cryptography {
|
|
if ((_machinePath == null) || (!_machinePathExists)) {
|
|
_machinePath = Path.Combine (
|
|
Environment.GetFolderPath (Environment.SpecialFolder.CommonApplicationData),
|
|
- ".mono");
|
|
+ "mono");
|
|
_machinePath = Path.Combine (_machinePath, "keypairs");
|
|
|
|
_machinePathExists = Directory.Exists (_machinePath);
|