ced2e58719
1. Make the 700 bit/s codec sound better, to improve speech quality on low SNR HF channels (beneath 0dB). 2. Develop a higher quality mode in the 2000 to 3000 bit/s range, that can be used on HF channels with modest SNRs (around 10dB)
14 lines
472 B
Text
14 lines
472 B
Text
--- unittest/CMakeLists.txt.orig 2017-06-12 01:04:28 UTC
|
|
+++ unittest/CMakeLists.txt
|
|
@@ -91,7 +91,10 @@ add_executable(tnewamp1 tnewamp1.c ../sr
|
|
target_link_libraries(tnewamp1 codec2)
|
|
|
|
add_executable(tsrc tsrc.c)
|
|
-target_link_libraries(tsrc samplerate)
|
|
+target_link_libraries(tsrc ${SAMPLERATE_LIBRARY})
|
|
+set_target_properties(tsrc
|
|
+ PROPERTIES INCLUDE_DIRECTORIES ${SAMPLERATE_INCLUDE_DIR}
|
|
+)
|
|
|
|
add_executable(tlininterp tlininterp.c)
|
|
add_executable(tdec tdec.c)
|