Also, moved patches under files/ PR: 223614 Submitted by: Jan Beich <jbeich@FreeBSD.org> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13051
13 lines
542 B
Makefile
13 lines
542 B
Makefile
--- Makefile.mk.orig 2016-01-25 10:55:48 UTC
|
|
+++ Makefile.mk
|
|
@@ -3,8 +3,8 @@
|
|
CC ?= gcc
|
|
|
|
# flags
|
|
-CFLAGS += -O3 -funroll-loops -ffast-math -fomit-frame-pointer -fstrength-reduce -Wall -Werror -fPIC -DPIC -I../utils
|
|
-LDFLAGS += -shared -Wl,-O1 -Wl,--as-needed -Wl,--no-undefined -Wl,--strip-all -lm -lrt
|
|
+CFLAGS += -funroll-loops -ffast-math -fomit-frame-pointer -Wall -Werror -fPIC -DPIC -I../utils
|
|
+LDFLAGS += -shared -Wl,--as-needed -Wl,--no-undefined -lm -lrt
|
|
|
|
ifneq ($(NOOPT),true)
|
|
CFLAGS += -mtune=generic -msse -msse2 -mfpmath=sse
|