12f56a38a7
* Use more bsd.port.mk convenience switches. * Use rc.subr properly for spread daemon. * Write a logfile rather than spewing to stdio. * Move rendezvous socket to /var/run. * Make Makefile.PL behave properly with PREFIX. PR: ports/60053 Submitted by: Joshua Goodall <joshua@roughtrade.net>
11 lines
342 B
C
11 lines
342 B
C
--- session.c Tue Aug 5 21:35:52 2003
|
|
+++ session.c Tue Aug 5 21:31:30 2003
|
|
@@ -406,7 +406,7 @@
|
|
Alarm( EXIT, "Sess_init: UNIX sock error\n" );
|
|
|
|
unix_addr.sun_family = AF_UNIX;
|
|
- sprintf( name, "/tmp/%d",My.port );
|
|
+ sprintf( name, "%s/spread.sock", _PATH_SPREAD_PIDDIR );
|
|
strcpy( unix_addr.sun_path, name );
|
|
unlink( name );
|
|
|