freebsd-ports/x11-toolkits/nucleo/files/patch-nucleo_image_sink_nudppImageSink.cxx
Alexey Dokuchaev db1377167d - Update to version 0.7.6
- Make libexif dependency mandatory: it is no longer considered optional by
  upstream sources, and there is no --without-exif configure script switch
- Ensure that optional dependencies are recorded correctly (prevent silent
  dependency injection)
- Augment list of available plugins (FFmpeg, GD) and add GnuTLS support
- Correctly depend on QT components (via bpm infrastructure)
- Clean up Makefile a bit and rearrange pkg-plist for better readability
2010-05-13 21:53:29 +00:00

12 lines
391 B
C++

--- nucleo/image/sink/nudppImageSink.cxx.orig 2010-05-14 03:50:14.379819227 +0700
+++ nucleo/image/sink/nudppImageSink.cxx 2010-05-14 03:55:16.360199694 +0700
@@ -18,6 +18,9 @@
#include <unistd.h>
#include <sys/socket.h>
#include <sys/uio.h>
+#if defined(__FreeBSD__) && __FreeBSD_version < 701104
+# include <netinet/in_systm.h>
+#endif
#include <netinet/ip.h>
#include <stdexcept>