freebsd-ports/www/py-graphite-web/files/patch-setup.py
Sunpoet Po-Chuan Hsieh 3a5eb3a413 - Update to 0.9.10
- While I'm here:
  - Update MASTER_SITES and WWW
  - Do not use 'cp -r' which is strongly discouraged
  - Pet portlint

Changes:	http://graphite.wikidot.com/
PR:		ports/169334
Submitted by:	Brad Davis <brd@FreeBSD.org>
Approved by:	Dan Rowe <drowe@wayfair.com> (maintainer)
2012-07-04 08:39:01 +00:00

25 lines
782 B
Python

--- setup.py.ori 2012-06-21 15:38:54.044808453 -0700
+++ setup.py 2012-06-21 15:41:16.067809618 -0700
@@ -15,11 +15,11 @@
storage_dirs = []
for subdir in ('whisper', 'rrd', 'log', 'log/webapp'):
- storage_dirs.append( ('storage/%s' % subdir, []) )
+ storage_dirs.append( ('graphite/storage/%s' % subdir, []) )
webapp_content = {}
-for root, dirs, files in os.walk('webapp/content'):
+for root, dirs, files in os.walk('graphite/webapp/content'):
for filename in files:
filepath = os.path.join(root, filename)
@@ -29,7 +29,7 @@
webapp_content[root].append(filepath)
-conf_files = [ ('conf', glob('conf/*.example')) ]
+conf_files = [ ('/usr/local/etc/graphite', glob('conf/*.example')) ]
examples = [ ('examples', glob('examples/example-*')) ]
setup(