freebsd-ports/net-mgmt/net-snmp4/files/patch-ak
Bill Fumerola 22667fa925 Upgrade to version 4.2
Some of the shared library magic is very hackish, however the net-snmp
library building make-fu is hackish as well, so I don't feel bad about it.

This commit also (re-)enables the host module for much more information.
It also fixes a long standing bug where 'snmpwalk localhost public' would
hang.
2001-01-18 09:58:30 +00:00

21 lines
860 B
Text

--- agent/Makefile.in.orig Sun Nov 19 12:58:06 2000
+++ agent/Makefile.in Wed Jan 17 18:37:02 2001
@@ -68,10 +68,18 @@
libucdagent.$(LIB_EXTENSION)$(LIB_VERSION): ${LLIBAGENTOBJS} libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION)
$(LIB_LD_CMD) libucdagent.$(LIB_EXTENSION)$(LIB_VERSION) ${LLIBAGENTOBJS} $(LIB_LD_LIBS)
+ ld -Bshareable -soname libucdagent.$(LIB_EXTENSION)$(LIB_VERSION) \
+ -o libucdagent.so ${LIBAGENTOBJS}
+ ln -f libucdagent.so \
+ ../libucdagent.so.4
$(RANLIB) libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION)
libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION): ${LMIBOBJS}
$(LIB_LD_CMD) libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION) ${LMIBOBJS} $(LIB_LD_LIBS)
+ ld -Bshareable -soname libucdmibs.so.4 \
+ -o libucdmibs.so ${MIBOBJS}
+ ln -f libucdmibs.so \
+ ../libucdmibs.so.4
$(RANLIB) libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION)
clean: