304e31afd7
o mozilla 1.0 dependency issue 1. reduce gtk dependency to xlib 2. we need libIDL >=0.6.3 and glib >=1.2.0 to build mozilla. From mozilla/xpcom/typelib/xpidl/README xpidl depends on Andrew Veliath and Elliot Lee's libIDL, a part of the GNOME ORBit C ORB. We currently require libIDL >= 0.6.3, which in turn requires glib >= 1.2.0 3. libIDL (not libIDL2) port does not exist and orbit includes libIDL and libIDL dependency implies glib12 o No longer depends on Xvfb. o Afaik, only JDK 1.4 is supported to build
44 lines
1.4 KiB
Text
44 lines
1.4 KiB
Text
#iZ 28398
|
|
#iZ 11424
|
|
|
|
http://qa.openoffice.org/issues/show_bug.cgi?id=28398
|
|
http://qa.openoffice.org/issues/show_bug.cgi?id=11424
|
|
|
|
disable freetype2 support since build broken and
|
|
this functionality is not used at all.
|
|
|
|
--- moz/extractfiles.mk.org Sat Oct 30 22:01:49 2004
|
|
+++ moz/extractfiles.mk Sat Oct 30 22:00:21 2004
|
|
@@ -269,8 +269,8 @@
|
|
+$(COPY) /QSZ $(INCLUDE_PATH)* $(INCLUDE_DIR)
|
|
+$(COPY) /QSZ $(PUBLIC_PATH)* $(INCLUDE_DIR)
|
|
.ELSE
|
|
- +$(GNUCOPY) -pr $(INCLUDE_PATH)* $(INCLUDE_DIR)
|
|
- +$(GNUCOPY) -pr $(PUBLIC_PATH)* $(INCLUDE_DIR)
|
|
+ +$(GNUCOPY) -Lr $(INCLUDE_PATH)* $(INCLUDE_DIR)
|
|
+ +$(GNUCOPY) -Lr $(PUBLIC_PATH)* $(INCLUDE_DIR)
|
|
.ENDIF
|
|
|
|
.IF "$(GUI)"=="UNX"
|
|
|
|
--- moz/mozilla-source-1.0.patch.org Tue Feb 10 19:44:34 2004
|
|
+++ moz/mozilla-source-1.0.patch Sat Mar 19 12:51:35 2005
|
|
@@ -4471,14 +4471,16 @@
|
|
return NS_OK;
|
|
}
|
|
|
|
---- miss/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
|
|
+--- misc/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
|
|
+++ misc/build/mozilla/.mozconfig Mon Jul 28 15:07:20 2003
|
|
-@@ -0,0 +1,8 @@
|
|
+@@ -0,0 +1,10 @@
|
|
+ac_add_options --disable-tests
|
|
+ac_add_options --disable-xprint
|
|
+ac_add_options --without-system-zlib
|
|
+ac_add_options --enable-ldap
|
|
+ac_add_options --disable-debug
|
|
++ac_add_options --disable-freetype2
|
|
++ac_add_options --enable-default-toolkit=xlib
|
|
+ac_add_options --enable-optimize
|
|
+ac_add_options --enable-crypto
|
|
+ac_add_options --enable-strip
|