freebsd-ports/cad/z88/files/patch-make_make__unix__64_z88g.mk.gcc64
Kurt Jaeger d460c1a711 cad/z88: update 13.0 -> 15
- Changes PORTVERSION to DISTVERSION
- Sets submitter as MAINTAINER.
- Uses USE_GITHUB instead of MASTER_SITES
- Sets LICENSE
- Sets appropriate dependencies, USES, USE_X
- Adds an EXAMPLES option
- Adds a pkg-message to explain how the port must be used, as it
  is not self-evident (The software assumes all files in the same
  directory instead of distributed into bin/, ${DATADIR} etc so I had
  to find a work around: the solution is easy for the user).

PR:		233772
Submitted by:	Lorenzo Salvadore <phascolarctos@protonmail.ch>
Reviewed by:	chitty_cloud@me.com
Relnotes:	https://forum.z88.de/viewtopic.php?f=18&t=885
2018-12-31 13:33:55 +00:00

12 lines
490 B
Text

--- make/make_unix_64/z88g.mk.gcc64.orig 2018-12-05 14:30:53 UTC
+++ make/make_unix_64/z88g.mk.gcc64
@@ -13,8 +13,7 @@ CFLAGS = -I$(DIRCOM) -DFR_UNIX -DFR_XDOU
LDLIBSOX = -lm -lc
-OBJECTSG = z88g.o ale88g.o clr88.o stop88g.o cosm88.o nast88.o dnas88.o\
- who88g.o wlog88g.o wrim88g.o lan88g.o
+OBJECTSG = z88g.o ale88g.o clr88.o stop88g.o cosm88.o nast88.o dnas88.o who88g.o wlog88g.o wrim88g.o lan88g.o
z88g: $(OBJECTSG)
$(CC) $(CFLAGS) -o $@ $(OBJECTSG) $(LDLIBSOX)