freebsd-ports/games/blockout/files/patch-Makefile
Tobias Kortkamp de9bba1607 Remove ALSA dependency. It's not required.
Approved by:	lme (mentor)
Differential Revision:	https://reviews.freebsd.org/D10730
2017-05-30 16:38:56 +00:00

40 lines
994 B
Text

--- BlockOut/Makefile.orig 2014-05-06 09:47:56 UTC
+++ BlockOut/Makefile
@@ -47,27 +47,27 @@ else
SDL_LIBS = /usr/lib/i386-linux-gnu
endif
-CXX = g++
+#CXX = g++
ifdef _release
-CXXFLAGS = -O2 -Dlinux -c \
- -I/usr/include/SDL -I../ImageLib/src -I.
+CXXFLAGS += -Dlinux -c \
+ -I$(LOCALBASE)/include/SDL -I$(LOCALBASE)/include -I../ImageLib/src -I.
LFLAGS = -Wl,--strip-all \
$(ADD_LIBS) \
- -lSDL_mixer -lSDL -lasound \
- -lGL -lGLU -lpthread -lm -ldl
+ -lSDL_mixer -lSDL \
+ -lGL -lGLU -lpthread -lm
else
-CXXFLAGS = -g -D_DEBUG -Dlinux -c \
- -I/usr/include/SDL -I../ImageLib/src -I.
+CXXFLAGS += -D_DEBUG -Dlinux -c \
+ -I$(LOCALBASE)/include/SDL -I$(LOCALBASE)/include -I../ImageLib/src -I.
-LFLAGS = -L $(SDL_LIBS) \
+LFLAGS = -L $(LOCALBASE)/lib \
$(ADD_LIBS) \
- -lSDL_mixer -lSDL -lasound \
- -lGL -lGLU -lpthread -lm -ldl
+ -lSDL_mixer -lSDL \
+ -lGL -lGLU -lpthread -lm
endif