freebsd-ports/www/py-cactus/files/patch-setup.py
Kubilay Kocak a13bb89f31 [NEW] www/py-cactus: Static site generator for designers
Cactus is a simple but powerful static website generator using Python
and the Django template system. Cactus also makes it easy to develop
locally and deploy your site to S3 directly. It works great for
company, portfolio, personal, support websites and blogs.

To get a quick overview watch this short video tutorial:

  https://vimeo.com/46999791

WWW: http://github.com/koenbok/Cactus
2015-09-01 07:34:24 +00:00

22 lines
619 B
Python

--- setup.py.orig 2015-04-05 13:19:03 UTC
+++ setup.py
@@ -118,7 +118,7 @@ setup(
],
},
install_requires=[
- 'Django==1.5.5',
+ 'Django>=1.5.5,<1.7',
'markdown2',
'argparse',
'keyring',
@@ -132,8 +132,8 @@ setup(
'Mac Native FSEvents': ['macfsevents'],
},
zip_safe=False,
- setup_requires=['nose'],
- tests_require=['nose', 'mock', 'tox', 'unittest2'],
+ tests_require=['nose', 'mock', 'unittest2'],
+ test_suite="nose.collector",
classifiers=[
"Development Status :: 4 - Beta",
"Environment :: Console",