freebsd-ports/editors/openoffice-1.1/files/patch-freetype+makefile.mk
Martin Blapp 13bf943c62 Only use -g if $debug is true. I'll suggest this also to the
OO.org people.

It would make sence to have a additional GMAKECFLAGS in solvenv,
which could contain a basic CFLAGS configuration. We cannot use
$CFLAGS cause there are dmake specific things in it.
2002-07-31 22:57:55 +00:00

24 lines
649 B
Makefile

--- ../freetype/makefile.mk.orig Tue Feb 26 12:21:37 2002
+++ ../freetype/makefile.mk Thu Aug 1 00:51:46 2002
@@ -79,7 +79,11 @@
#relative to CONFIGURE_DIR
CONFIGURE_ACTION=$(GNUMAKE)
.IF "$(GUI)"=="UNX"
-CONFIGURE_FLAGS=setup
+.IF "$(debug)"==""
+CONFIGURE_FLAGS=setup CFLAGS="-O"
+.ELSE # "$(debug)"==""
+CONFIGURE_FLAGS=setup CFLAGS="-O -g -ggdb"
+.ENDIF # "$(debug)"==""
.ELSE # "$(GUI)"=="UNX"
CONFIGURE_FLAGS=setup visualc
.ENDIF # "$(GUI)"=="UNX"
@@ -90,7 +94,7 @@
.IF "$(GUI)"=="UNX"
OUT2LIB= \
objs$/.libs$/libfreetype.a \
- objs$/.libs$/libfreetype.so.6*
+ objs$/.libs$/libfreetype.so.7
.ENDIF # "$(GUI)"=="UNX"