Drop support for 4.x Add an additional mirror PR: 96488 Submitted by: Emanuel Haupt <ehaupt@FreeBSD.org>
43 lines
2.3 KiB
Text
43 lines
2.3 KiB
Text
--- src/frontends/xmms/Makefile.in.orig Sun Dec 10 12:02:29 2006
|
|
+++ src/frontends/xmms/Makefile.in Sun Dec 10 12:01:15 2006
|
|
@@ -5,7 +5,7 @@
|
|
XMMSFLAGS={XMMSFLAGS}
|
|
XMMSLIBS={XMMSLIBS}
|
|
SHAREDLIBRARYFLAGS={SHAREDLIBRARYFLAGS}
|
|
-CFLAGS = -Wall -O2 $(SHAREDLIBRARYFLAGS) $(DEBUGFLAGS) $(XMMSFLAGS) $(ARCHFLAGS) -I../common -I../../include
|
|
+CFLAGS = $(SHAREDLIBRARYFLAGS) $(DEBUGFLAGS) $(XMMSFLAGS) $(ARCHFLAGS) -I../common -I../../include
|
|
CLIBS = $(XMMSLIBS) -lm
|
|
MODULES = plugin.o amifilemagic.o eagleplayer.o strlrep.o uadecontrol.o \
|
|
uadeipc.o unixatomic.o subsongseek.o effects.o uadeconf.o md5.o \
|
|
--- src/Makefile.in.orig Sun Dec 10 12:02:22 2006
|
|
+++ src/Makefile.in Sun Dec 10 12:01:35 2006
|
|
@@ -4,7 +4,7 @@
|
|
ARCHLIBS = {ARCHLIBS}
|
|
DEBUGFLAGS = {DEBUGFLAGS}
|
|
|
|
-COMMONGCCOPTS = -Wall -Wno-unused -Wno-format -Wmissing-prototypes -Wstrict-prototypes -fno-exceptions -O2
|
|
+COMMONGCCOPTS = -Wno-unused -Wno-format -Wmissing-prototypes -Wstrict-prototypes -fno-exceptions
|
|
|
|
TARGETCFLAGS = -fomit-frame-pointer -DGCCCONSTFUNC="__attribute__((const))" -D_REENTRANT -DREGPARAM= -D__inline__=inline $(COMMONGCCOPTS) $(DEBUGFLAGS) $(ARCHFLAGS)
|
|
LIBRARIES = -lm $(AUDIOLIBS) $(ARCHLIBS)
|
|
--- src/frontends/uade123/Makefile.in.orig Sun Dec 10 12:02:16 2006
|
|
+++ src/frontends/uade123/Makefile.in Sun Dec 10 12:01:08 2006
|
|
@@ -1,6 +1,6 @@
|
|
|
|
CC = {CC}
|
|
-CFLAGS = -Wall -O2 -I../../include -I../common {AOFLAGS} {DEBUGFLAGS} {ARCHFLAGS}
|
|
+CFLAGS = -I../../include -I../common {AOFLAGS} {DEBUGFLAGS} {ARCHFLAGS}
|
|
CLIBS = {AOLIBS} {ARCHLIBS} -lm
|
|
MODULES = uade123.o strlrep.o unixatomic.o uadeipc.o amifilemagic.o \
|
|
chrarray.o playlist.o eagleplayer.o unixwalkdir.o effects.o \
|
|
--- src/frontends/audacious/Makefile.in.orig Sun Dec 10 12:02:10 2006
|
|
+++ src/frontends/audacious/Makefile.in Sun Dec 10 12:00:55 2006
|
|
@@ -5,7 +5,7 @@
|
|
AUDACIOUSFLAGS={AUDACIOUSFLAGS}
|
|
AUDACIOUSLIBS={AUDACIOUSLIBS}
|
|
SHAREDLIBRARYFLAGS={SHAREDLIBRARYFLAGS}
|
|
-CFLAGS = -Wall -O2 $(SHAREDLIBRARYFLAGS) $(AUDACIOUSFLAGS) $(ARCHFLAGS) $(DEBUGFLAGS) -I../common -I../../include
|
|
+CFLAGS = $(SHAREDLIBRARYFLAGS) $(AUDACIOUSFLAGS) $(ARCHFLAGS) $(DEBUGFLAGS) -I../common -I../../include
|
|
CLIBS = $(XMLIBS) -lm
|
|
MODULES = plugin.o amifilemagic.o eagleplayer.o strlrep.o uadecontrol.o \
|
|
uadeipc.o unixatomic.o subsongseek.o effects.o uadeconf.o md5.o \
|