freebsd-ports/security/openssh/files/patch-lib-Makefile
Dirk Meyer f4eb252ac6 Update to OpenSSH 3.2.3
- patch openssh-3.1-adv.token.patch is now obsolete.
- remerged PAM changes form previous port
- declare CMSG_* macros.
- fixed bad type in function input_userauth_passwd_changereq

Update to OpenSSH-portable-3.2.3p1

- patch openssh-3.1p1-adv.token.patch is now obsolete
- keep previously declared CONFIGURE_ARGS
- remove openssh-mit-krb5-20020326.diff (should be in the distribution now)
- patch patch-readpassphrase.c is now in teh distribution
- merged previous patches.
- extend CONFIGURE_ARGS so it find OPENSSL again.
- new patches for GSSAPI, not fully tested.

If you have the patch applied:
http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/36080

Builds with openssl-0.9.6d under:
2.2.8-RELEASE
3.2-RELEASE
4.2-RELEASE
4.6-RC
2002-05-31 07:28:46 +00:00

23 lines
574 B
Text

--- lib/Makefile.orig Thu May 23 13:12:23 2002
+++ lib/Makefile Thu May 23 13:14:17 2002
@@ -11,6 +11,11 @@
rijndael.c ssh-dss.c ssh-rsa.c dh.c kexdh.c kexgex.c \
scard.c monitor_wrap.c monitor_fdpass.c
+SRCS+= strlcpy.c strlcat.c
+.if defined(COMPAT_GETADDRINFO)
+SRCS+= getaddrinfo.c getnameinfo.c name6.c rcmd.c bindresvport.c
+.endif
+
SRCS+= readpassphrase.c
DEBUGLIBS= no
@@ -21,6 +26,8 @@
@echo -n
.include <bsd.own.mk>
+IGNORE_LIBSSH=yes
+.include "../Makefile.inc"
.if (${KERBEROS:L} == "yes")
CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV