Remove the recently added ARM patch. This port has always been limited to amd64 and i386 so patching ARM code has no effect.
137 lines
4 KiB
Text
137 lines
4 KiB
Text
--- gcc/config/dragonfly.h.orig
|
|
+++ gcc/config/dragonfly.h
|
|
@@ -84,7 +84,7 @@
|
|
} \
|
|
%{static:-Bstatic} \
|
|
} \
|
|
- %{!static:--hash-style=gnu} \
|
|
+ %{!static:--hash-style=gnu -rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
|
|
#undef LINK_SPEC
|
|
--- gcc/config/i386/freebsd.h.orig
|
|
+++ gcc/config/i386/freebsd.h
|
|
@@ -77,6 +77,12 @@
|
|
When the -shared link option is used a final link is not being
|
|
done. */
|
|
|
|
+#if FBSD_MAJOR < 10
|
|
+#define ELF_HASH_STYLE "--hash-style=both "
|
|
+#else
|
|
+#define ELF_HASH_STYLE "--hash-style=gnu "
|
|
+#endif
|
|
+
|
|
#undef LINK_SPEC
|
|
#define LINK_SPEC "\
|
|
%{p:%nconsider using '-pg' instead of '-p' with gprof(1)} \
|
|
@@ -88,6 +94,7 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker %(fbsd_dynamic_linker) } \
|
|
%{static:-Bstatic}} \
|
|
+ %{!static:" ELF_HASH_STYLE "-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
|
|
/* A C statement to output to the stdio stream FILE an assembler
|
|
--- gcc/config/i386/freebsd64.h.orig
|
|
+++ gcc/config/i386/freebsd64.h
|
|
@@ -41,4 +41,5 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker %(fbsd_dynamic_linker) } \
|
|
%{static:-Bstatic}} \
|
|
+ %{!static:" ELF_HASH_STYLE "-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
--- libiberty/getpagesize.c.orig
|
|
+++ libiberty/getpagesize.c
|
|
@@ -20,6 +20,7 @@
|
|
|
|
*/
|
|
|
|
+#ifndef __ANDROID__
|
|
#ifndef VMS
|
|
|
|
#include "config.h"
|
|
@@ -88,3 +89,4 @@
|
|
}
|
|
|
|
#endif /* VMS */
|
|
+#endif /* __ANDROID__ */
|
|
--- libiberty/setproctitle.c.orig
|
|
+++ libiberty/setproctitle.c
|
|
@@ -40,9 +40,11 @@
|
|
void
|
|
setproctitle (const char *name ATTRIBUTE_UNUSED, ...)
|
|
{
|
|
+#ifndef __ANDROID__
|
|
#ifdef PR_SET_NAME
|
|
/* On GNU/Linux this sets the top visible "comm", but not
|
|
necessarily the name visible in ps. */
|
|
prctl (PR_SET_NAME, name);
|
|
#endif
|
|
+#endif
|
|
}
|
|
--- gcc/Makefile.in.orig
|
|
+++ gcc/Makefile.in
|
|
@@ -1163,7 +1163,6 @@
|
|
insn-emit.o \
|
|
insn-extract.o \
|
|
insn-latencytab.o \
|
|
- insn-modes.o \
|
|
insn-opinit.o \
|
|
insn-output.o \
|
|
insn-peep.o \
|
|
@@ -1518,6 +1517,7 @@
|
|
$(OBJS-libcommon-target) @TREEBROWSER@ main.o c-family/cppspec.o \
|
|
$(COLLECT2_OBJS) $(EXTRA_GCC_OBJS) $(GCOV_OBJS) $(GCOV_DUMP_OBJS) \
|
|
$(GCOV_TOOL_OBJS) $(GENGTYPE_OBJS) gcc-ar.o gcc-nm.o gcc-ranlib.o \
|
|
+ insn-modes.o insn-modes-ada.o \
|
|
lto-wrapper.o collect-utils.o
|
|
|
|
# This lists all host object files, whether they are included in this
|
|
@@ -1525,6 +1525,11 @@
|
|
ALL_HOST_OBJS = $(ALL_HOST_FRONTEND_OBJS) $(ALL_HOST_BACKEND_OBJS)
|
|
|
|
BACKEND = libbackend.a main.o @TREEBROWSER@ libcommon-target.a libcommon.a \
|
|
+ insn-modes.o \
|
|
+ $(CPPLIB) $(LIBDECNUMBER)
|
|
+
|
|
+BACKEND2 = libbackend.a main.o @TREEBROWSER@ libcommon-target.a libcommon.a \
|
|
+ insn-modes-ada.o \
|
|
$(CPPLIB) $(LIBDECNUMBER)
|
|
|
|
# This is defined to "yes" if Tree checking is enabled, which roughly means
|
|
@@ -2171,6 +2176,7 @@
|
|
|
|
insn-modes.c: s-modes; @true
|
|
insn-modes.h: s-modes-h; @true
|
|
+insn-modes-ada.c: s-modes-ada; @true
|
|
min-insn-modes.c: s-modes-m; @true
|
|
|
|
s-modes: build/genmodes$(build_exeext)
|
|
@@ -2188,6 +2194,12 @@
|
|
$(SHELL) $(srcdir)/../move-if-change tmp-min-modes.c min-insn-modes.c
|
|
$(STAMP) s-modes-m
|
|
|
|
+s-modes-ada: s-modes
|
|
+ $(shell sed -e 's/: TARGET_96_ROUND_53_LONG_DOUBLE \? &ieee_extended_intel_96_round_53_format //' \
|
|
+ < insn-modes.c > tmp-modes-ada.c)
|
|
+ $(SHELL) $(srcdir)/../move-if-change tmp-modes-ada.c insn-modes-ada.c
|
|
+ $(STAMP) s-modes-ada
|
|
+
|
|
insn-preds.c: s-preds; @true
|
|
tm-preds.h: s-preds-h; @true
|
|
tm-constrs.h: s-constrs-h; @true
|
|
@@ -3333,6 +3345,9 @@
|
|
( cd $(DESTDIR)$(bindir) && \
|
|
$(LN) $(GCC_INSTALL_NAME)$(exeext) $(FULL_DRIVER_NAME) ); \
|
|
fi; \
|
|
+ if [ -f gnat1$(exeext) ] ; then \
|
|
+ ( cd $(DESTDIR)$(bindir) && $(LN) $(GCC_INSTALL_NAME)$(exeext) ada$(exeext) ) \
|
|
+ fi; \
|
|
if [ ! -f gcc-cross$(exeext) ] \
|
|
&& [ "$(GCC_INSTALL_NAME)" != "$(GCC_TARGET_INSTALL_NAME)" ]; then \
|
|
rm -f $(DESTDIR)$(bindir)/$(target_noncanonical)-gcc-tmp$(exeext); \
|
|
--- libgcc/config/i386/t-dragonfly.orig
|
|
+++ libgcc/config/i386/t-dragonfly
|
|
@@ -0,0 +1,2 @@
|
|
+# Required for -fcilkplus support
|
|
+SHLIB_MAPFILES += $(srcdir)/config/i386/libgcc-bsd.ver
|