- rework KDE4_BUILDENV All ports: - remove needless post-extract target - make patches relative to ${PATCH_WRKSRC} - clean up - bump PORTREVISION when required databases/akonadi: - replace dependency on boost-python-libs with boost-libs (finally, boost-pyhton does not conflict with boost \o/) deskutils/kdepim*: - replace boost-python-libs with boost-libs - reduce dependencies - respect PREFIX - fix build with qt3 installed misc/kdeedu4: - add dependency on astro/xplanet (for KStars) misc/kdeutils4: - add dependency on devel/qca (for okteta) - make dependency on kdebase non-optional multimedia/kdemultimedia4: - add optional support for PulseAudio x11/kdebase4: - remove needless dependency on kdebase4-runtime x11/kdebase4-runtime, x11/kdebase4-workspace - remove extra CMAKE_ARGS to fix build for qt3/kde3 users x11/kdelibs4 - remove needless dependencies - remove extra CMAKE_ARGS to fix build for qt3/kde3 users
11 lines
624 B
Text
11 lines
624 B
Text
--- ./CMakeLists.txt.orig 2009-08-10 19:43:44.000000000 +1100
|
|
+++ ./CMakeLists.txt 2009-08-10 19:58:07.000000000 +1100
|
|
@@ -47,7 +47,7 @@
|
|
|
|
############### Needed commands before building anything ###############
|
|
|
|
-include_directories(${kdepim-runtime_SOURCE_DIR} ${kdepim-runtime_BINARY_DIR} ${AKONADI_INCLUDE_DIR} ${Boost_INCLUDE_DIR} ${KDE4_INCLUDES} ${KDEPIMLIBS_INCLUDE_DIRS})
|
|
+include_directories(${kdepim-runtime_SOURCE_DIR} ${kdepim-runtime_BINARY_DIR} ${KDE4_INCLUDES} ${KDEPIMLIBS_INCLUDE_DIRS} ${AKONADI_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
|
|
|
|
|