46 lines
1.7 KiB
Text
46 lines
1.7 KiB
Text
|
|
$FreeBSD$
|
|
|
|
--- src/Makefile.orig Thu May 30 17:51:53 2002
|
|
+++ src/Makefile Wed Jun 5 15:47:41 2002
|
|
@@ -48,6 +48,7 @@
|
|
|
|
## Set the following to a list of pathnames to be copied to $(CANONDIR)
|
|
CANON_TOPLEVELFILES= $(ABI_ROOT)/COPYING $(ABI_ROOT)/user/wp/readme.txt
|
|
+CANON_TLF_NOTDIR= $(notdir $(CANON_TOPLEVELFILES))
|
|
|
|
## Set the following to a list of directories (probably a subset of DIRS)
|
|
## that have work to do.
|
|
@@ -58,6 +59,9 @@
|
|
@for k in $(CANON_TOPLEVELFILES); do \
|
|
$(ABICOPY) $$k $(CANONDIR); \
|
|
done
|
|
+ @for k in $(CANON_TLF_NOTDIR); do \
|
|
+ $(ABICHMOD) ugo=r $(CANONDIR)/$$k; \
|
|
+ done
|
|
@for k in $(CANON_SubDirs); do \
|
|
$(MAKE) ABI_ROOT=$(ABI_ROOT) -C $$k canonical; \
|
|
done
|
|
@@ -72,6 +76,7 @@
|
|
cp $$k american.hash; \
|
|
rm $$k ; \
|
|
done)
|
|
+ @(cd $(CANONDIR)/dictionary; $(ABICHMOD) ugo=r *)
|
|
# We currently only ship american.hash, so the above and below aren't logical.
|
|
# For same reason, this will only copy american.hash-encoding once in place. The rest is in abispell.
|
|
@$(ABICOPY) $(ABI_ROOT)/../abidistfiles/dictionary/*.hash-encoding $(CANONDIR)/dictionary
|
|
@@ -112,10 +117,12 @@
|
|
fi
|
|
# icons for X window manager use
|
|
@$(subst xxxx,$(CANONDIR)/icons,$(VERIFY_DIRECTORY))
|
|
- (cd $(ABI_ROOT)/../abidistfiles/icons; cp abi* $(CANONDIR)/icons)
|
|
+ (cd $(ABI_ROOT)/../abidistfiles/icons; $(ABICOPY) abi* $(CANONDIR)/icons)
|
|
+ @(cd $(CANONDIR)/icons; $(ABICHMOD) ugo=r *_48*)
|
|
# font stuff for installation
|
|
@$(subst xxxx,$(CANONDIR)/fonts,$(VERIFY_DIRECTORY))
|
|
- (cd $(ABI_ROOT)/../unixfonts/fonts ; cp *.* $(CANONDIR)/fonts)
|
|
+ (cd $(ABI_ROOT)/../unixfonts/fonts ; $(ABICOPY) *.* $(CANONDIR)/fonts)
|
|
+ @(cd $(CANONDIR)/fonts; $(ABICHMOD) ugo=r *.*)
|
|
endif
|
|
|
|
##################################################################
|