freebsd-ports/audio/gogglesmm/files/patch-CMakeLists.txt
Jason E. Hale 3caf6b12c5 Chase x11-toolkits/fox17 update
Fix shebangs

Make importer scripts optional, they require python and probably aren't used
all that much.
2018-02-16 11:05:58 +00:00

42 lines
1.8 KiB
Text

--- CMakeLists.txt.orig 2017-06-10 02:18:06 UTC
+++ CMakeLists.txt
@@ -57,6 +57,11 @@ if(HAS_CXX_OPTIMIZE_DEBUG AND CMAKE_BUILD_TYPE MATCHES
add_compile_options(-Og)
endif()
+CHECK_CXX_COMPILER_FLAG(-Wno-inconsistent-missing-override HAS_CXX_NOOVERRIDE)
+if(HAS_CXX_NOOVERRIDE AND NOT CMAKE_BUILD_TYPE MATCHES Debug)
+ add_compile_options(-Wno-inconsistent-missing-override)
+endif()
+
# FIXME Doesn't work on all platforms.
#CHECK_CXX_COMPILER_FLAG(-flto HAS_CXX_OPTIMIZE_LINKTIME)
if(HAS_CXX_OPTIMIZE_LINKTIME AND NOT CMAKE_BUILD_TYPE MATCHES Debug)
@@ -81,11 +86,13 @@ add_subdirectory(src)
#-------------------------------------------------------------------------------
# Extra Installation Files
-install(PROGRAMS extra/import_banshee_stats.py
- extra/import_gogglesmm12.py
- extra/import_gogglesmm12_stats.py
- DESTINATION
- share/gogglesmm)
+if(WITH_IMPORT)
+ install(PROGRAMS extra/import_banshee_stats.py
+ extra/import_gogglesmm12.py
+ extra/import_gogglesmm12_stats.py
+ DESTINATION
+ share/gogglesmm)
+endif()
install(FILES icons/gogglesmm_16.png DESTINATION share/icons/hicolor/16x16/apps RENAME gogglesmm.png)
install(FILES extra/gogglesmm_22.png DESTINATION share/icons/hicolor/22x22/apps RENAME gogglesmm.png)
@@ -96,7 +103,7 @@ install(FILES extra/gogglesmm_64.png DESTINATION share
install(FILES extra/gogglesmm.svg DESTINATION share/icons/hicolor/scalable/apps RENAME gogglesmm.svg)
install(FILES extra/gogglesmm.appdata.xml DESTINATION share/appdata)
install(FILES extra/gogglesmm.desktop DESTINATION share/applications)
-install(FILES extra/gogglesmm.1 DESTINATION share/man/man1)
+install(FILES extra/gogglesmm.1 DESTINATION man/man1)
# Install translations when native language support has been enabled
if(WITH_NLS)