freebsd-ports/print/tex-xdvik/files/patch-texk-xdvik-tests-Makefile.am
Hiroki Sato 90410e570d Update TeXLive to TL2015.
- print/texlive-infra was renamed with print/texlive-tlmgr.
  Note that currently tlmgr(1) does not work because of
  lack of TLPDB.  This will be fixed.

- Lua libraries used in LuaTeX are separated into
  devel/tex-libtexlua and devel/texlibtexluajit.
  USE_TEX supports them via keywords "texlua" and "texluajit".

- libsynctex is currently installed by devel/tex-web2c.
  This will be separated into a single port.

- Add graphics/libpotrace and use installed libpotrace
  and libharfbuzz.
2015-07-19 20:33:34 +00:00

21 lines
510 B
Text

--- texk/xdvik/tests/Makefile.am.orig 2013-03-13 20:24:29 UTC
+++ texk/xdvik/tests/Makefile.am
@@ -22,11 +22,17 @@ run_tests_SOURCES = \
$(run_tests_OBJECTS): ../libxdvi.a $(common_dependencies)
-LDADD = ../libxdvi.a $(common_ldadd)
+LDADD = ../libxdvi.a $(common_ldadd) $(FREETYPE2_LIBS) $(ZLIB_LIBS)
../libxdvi.a: $(libxdvi_dependencies)
cd .. && $(MAKE) $(AM_MAKEFLAGS) libxdvi.a
+## Rebuild libfreetype
+@FREETYPE2_RULE@
+
+## Rebuild libz
+@ZLIB_RULE@
+
## Not used
##
EXTRA_DIST = test1.c