freebsd-ports/graphics/fotoxx/files/patch-fotoxx.h
Matthias Andree 92500c08eb Unbreak and upgrade to new upstream release 14.02.2.
Based on a patch to upgrade to 14.01.1 by Rainer Hurling,
based on a patch to upgrade to 13.03.1 by Rod Person.

Rainer's changes:
- new mastersite; 2nd mastersites contents has to be updated
- unbreak the port
- modernize LIB_DEPENDS
- support STAGE_DIR
- strip bin/fotoxx
- correct usage of desktop-file-utils
- update URL in pkg-descr
- update pkg-plist

Committer's changes:
- work around fetch(1)/nginx incompatibility making fetch commands with
  unmerged fix r261263 (and ancestors) unable to fetch from the primary
  site.
- add USES=pkgconfig
- add mirror sites
- fix installation of manfile
- fix paths in desktop file
- stop using xdg-desktop-menu for now, breaks the build and does not
  appear to be required

PR:		ports/177643
Submitted by:	Rod Person, Rainer Hurling
2014-02-07 01:01:37 +00:00

13 lines
1 KiB
C

--- ./fotoxx.h.orig 2014-02-05 20:42:34.000000000 +0100
+++ ./fotoxx.h 2014-02-06 10:32:37.000000000 +0100
@@ -339,8 +339,8 @@
EX int dww, dhh; // Dpxb size in drawing window, <= Dww, Dhh
EX int zoomx, zoomy; // req. zoom center of window
-EX mutex Fpixmap_lock; // lock for accessing PXM pixmaps
-EX mutex preload_lock; // lock for image file preload function
+EX mutex_tp Fpixmap_lock; // lock for accessing PXM pixmaps
+EX mutex_tp preload_lock; // lock for image file preload function
EX int Mbutton; // mouse button, 1/3 = left/right
EX int Mwxposn, Mwyposn; // mouse position, window space