1dcd559cd5
- lots of changes PR: 227677 Submitted by: Ben Hood <ben@relops.com> Relnotes: https://www.kamailio.org/w/kamailio-v5-1-0-release-notes/ https://www.kamailio.org/pub/kamailio/5.1.3/ChangeLog https://www.kamailio.org/pub/kamailio/5.1.2/ChangeLog https://www.kamailio.org/pub/kamailio/5.1.1/ChangeLog https://www.kamailio.org/pub/kamailio/5.1.0/ChangeLog https://www.kamailio.org/pub/kamailio/5.0.6/ChangeLog Security: CVE-2018-8828
21 lines
657 B
Text
21 lines
657 B
Text
--- utils/kamctl/Makefile.orig 2018-03-01 16:24:11 UTC
|
|
+++ utils/kamctl/Makefile
|
|
@@ -8,6 +8,8 @@ else
|
|
kamctltmpdir = $(basedir)
|
|
endif
|
|
|
|
+skip_cfg_install?=yes
|
|
+
|
|
all:
|
|
@echo "No compilation needed for kamctl"
|
|
|
|
@@ -20,7 +22,8 @@ install-cfg: $(cfg_prefix)/$(cfg_dir)
|
|
$(INSTALL_TOUCH) $(cfg_prefix)/$(cfg_dir)/kamctlrc.sample
|
|
$(INSTALL_CFG) kamctlrc \
|
|
$(cfg_prefix)/$(cfg_dir)/kamctlrc.sample
|
|
- if [ ! -f $(cfg_prefix)/$(cfg_dir)/kamctlrc ]; then \
|
|
+ if [ -z "${skip_cfg_install}" -a \
|
|
+ ! -f $(cfg_prefix)/$(cfg_dir)/kamctlrc ]; then \
|
|
mv -f $(cfg_prefix)/$(cfg_dir)/kamctlrc.sample \
|
|
$(cfg_prefix)/$(cfg_dir)/kamctlrc; \
|
|
fi
|