freebsd-ports/www/firefox36/files/patch-layout_generic_Makefile.in
Beat Gaetzi b98f720761 - Update to 3.6
What's new in Firefox 3.6:

  * Support for the HTML5 File API
  * A change to how third-party software integrates with Firefox to
    increase stability.
  * The ability to run scripts asynchronously to speed up page load times.
  * A mechanism to prevent incompatible software from crashing Firefox.
  * Users can now change their browser's appearance with a single click,
    with built in support for Personas.
  * Firefox 3.6 will alert users about out of date plugins to keep them
    safe.
  * Open, native video can now be displayed full screen, and supports
    poster frames.
  * Support for the WOFF font format.
  * Improved JavaScript performance, overall browser responsiveness and
    startup time.
  * Support for new CSS, DOM and HTML5 web technologies.

Thanks to:	Andreas Tobler, Florian Smeets, nox@, miwi@ and all testers
2010-02-07 21:48:44 +00:00

14 lines
415 B
Text

--- layout/generic/Makefile.in.orig 2009-08-07 00:49:41.000000000 +0200
+++ layout/generic/Makefile.in 2009-08-09 20:54:53.000000000 +0200
@@ -187,9 +187,10 @@
-I$(srcdir)/../../content/base/src \
-I$(srcdir)/../../content/html/content/src \
-I$(srcdir)/../../dom/base \
- $(MOZ_CAIRO_CFLAGS) \
$(NULL)
+CXXFLAGS += $(MOZ_CAIRO_CFLAGS)
+
ifdef MOZ_ENABLE_GTK2
CXXFLAGS += $(MOZ_GTK2_CFLAGS)
endif