freebsd-ports/databases/postgis/files/patch-GNUmakefile
Chin-San Huang c50c752d59 - Respect NOPORTDOCS.
- Respect USE_LDCONFIG.

PR:		ports/115808
Submitted by:	Sunpoet Po-Chuan Hsieh <sunpoet at sunpoet.net>
Approved by:	maintainer
2007-08-31 10:32:16 +00:00

48 lines
994 B
Text

--- GNUmakefile.orig 2007-07-11 05:12:42.000000000 +0800
+++ GNUmakefile 2007-08-31 17:41:49.000000000 +0800
@@ -4,9 +4,9 @@
#
#-----------------------------------------------------
-all: Makefile.config liblwgeom loaderdumper utils
+all: Makefile.config liblwgeom loaderdumper utils docs
-install: all liblwgeom-install loaderdumper-install
+install: all liblwgeom-install loaderdumper-install utils-install docs-install
uninstall: liblwgeom-uninstall loaderdumper-uninstall docs-uninstall
@@ -72,21 +72,31 @@
$(MAKE) -C extras/template_gis uninstall
docs: Makefile.config
- $(MAKE) -C doc
+ifndef NOPORTSDOC
+ $(MAKE) -C doc
+endif
docs-clean: Makefile.config
+ifndef NOPORTSDOC
$(MAKE) -C doc clean
-
+endif
docs-install:
+ifndef NOPORTSDOC
$(MAKE) -C doc install
+endif
docs-uninstall:
+ifndef NOPORTSDOC
$(MAKE) -C doc uninstall
+endif
utils:
$(MAKE) -C utils
+utils-install:
+ ${MAKE} -C utils install
+
configure: configure.in
./autogen.sh