freebsd-ports/devel/kf5-extra-cmake-modules/files/patch-CMakeLists.txt
Tobias C. Berner 30a183cdd9 Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE
that serve as technological foundation for KDE Plasma 5 and KDE Applications
distributed under the GNU Lesser General Public License (LGPL) [1].

The work is based on what we have in the KDE testing repo [2].

This is the next big step in updating the KDE Desktop and its Applications
to anything less dusty.

With this change, `USES=kde:5` is now a valid option. Ports that need to depend
on KDE Framework can now set:
	USES=kde:5
	USE_KDE=<framework1> <framework2> ... <frameworkX>

For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via:
	KWALLET_USE=            KDE=wallet

I would like to thank Raphael and Adriaan for reviewing the ports in the testing
repo :)

[1] https://en.wikipedia.org/wiki/KDE_Frameworks
[2] http://src.mouf.net/area51/log/branches/plasma5

Reviewed by:	rakuco, mat, groot_kde.org
Approved by:	rakuco (maintainer)
Differential Revision:	https://reviews.freebsd.org/D8329
2016-11-14 16:12:56 +00:00

17 lines
558 B
Text

--- CMakeLists.txt.orig 2016-09-15 12:44:43 UTC
+++ CMakeLists.txt
@@ -76,12 +76,12 @@ set(KDE_MODULES_INSTALL_DIR ${SHAR
set(MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/ECM/modules/)
set(TOOLCHAIN_MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/ECM/toolchain/)
-set(DOC_INSTALL_DIR ${SHARE_INSTALL_DIR}/doc/ECM
+set(DOC_INSTALL_DIR ${SHARE_INSTALL_DIR}/doc/extra-cmake-modules
CACHE
PATH
"HTML and QtHelp documentation"
)
-set(MAN_INSTALL_DIR ${SHARE_INSTALL_DIR}/man
+set(MAN_INSTALL_DIR man
CACHE
PATH
"man pages"