c07ac0c4d8
Since I'm there, define the license. Requested by: bapt (1) X-Teaser: LibreOffice is coming!
54 lines
1.5 KiB
Text
54 lines
1.5 KiB
Text
--- src/Makefile.in.orig 2003-05-22 13:39:52.000000000 +0200
|
|
+++ src/Makefile.in 2010-12-09 21:29:22.000000000 +0100
|
|
@@ -126,18 +126,18 @@
|
|
|
|
WARNS = -W -Wall -Wshadow -Wpointer-arith
|
|
IFLAGS =
|
|
-FLAGS = -g -O3 -funroll-loops -D_THREAD_SAFE -D_GNU_SOURCE
|
|
+FLAGS = -g -funroll-loops -D_THREAD_SAFE -D_GNU_SOURCE
|
|
VERBOSE = -DVERBOSE
|
|
AM_CFLAGS = $(IFLAGS) $(VERBOSE) $(WARNS) $(FLAGS)
|
|
AM_LDFLAGS = -g
|
|
|
|
noinst_HEADERS = \
|
|
- common.h constants.h fingerprint.h textcat.h wg_mempool.h
|
|
+ common.h constants.h fingerprint.h textcat.h wg_mempool.h utf8misc.h
|
|
|
|
|
|
lib_LTLIBRARIES = libtextcat.la
|
|
libtextcat_la_SOURCES = \
|
|
- common.c fingerprint.c textcat.c wg_mempool.c
|
|
+ common.c fingerprint.c textcat.c wg_mempool.c utf8misc.c
|
|
|
|
|
|
bin_PROGRAMS = createfp
|
|
@@ -156,7 +156,7 @@
|
|
libtextcat_la_LDFLAGS =
|
|
libtextcat_la_LIBADD =
|
|
am_libtextcat_la_OBJECTS = common.lo fingerprint.lo textcat.lo \
|
|
- wg_mempool.lo
|
|
+ wg_mempool.lo utf8misc.lo
|
|
libtextcat_la_OBJECTS = $(am_libtextcat_la_OBJECTS)
|
|
bin_PROGRAMS = createfp$(EXEEXT)
|
|
noinst_PROGRAMS = testtextcat$(EXEEXT)
|
|
@@ -264,6 +264,11 @@
|
|
else :; fi; \
|
|
done
|
|
|
|
+install-HEADERS:
|
|
+ @$(NORMAL_INSTALL)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(pkgincludedir)
|
|
+ $(INSTALL_HEADER) $(HEADERS) $(DESTDIR)$(pkgincludedir)
|
|
+
|
|
uninstall-binPROGRAMS:
|
|
@$(NORMAL_UNINSTALL)
|
|
@list='$(bin_PROGRAMS)'; for p in $$list; do \
|
|
@@ -490,7 +495,7 @@
|
|
|
|
install-data-am:
|
|
|
|
-install-exec-am: install-binPROGRAMS install-libLTLIBRARIES
|
|
+install-exec-am: install-binPROGRAMS install-libLTLIBRARIES install-HEADERS
|
|
|
|
install-info: install-info-am
|
|
|