freebsd-ports/sysutils/cdrdao/files/patch-scsilib::RULES::i386-freebsd-cc.rul
Alexander Leidinger 5af2b1ef15 - Update to 1.1.8. Relevant parts from the release notes:
<snip>
  - Improved performance of the new L-EC code by up to a factor 2 depending
    on the hardware.
  - 'read-test' runs L-EC encoder over mode 1 or mode 2 form 1 sectors to
    allow performance testing in conjunction with option --speed.
  new:
  - toc2cddb: translates a TOC file into a cddb file. (Giuseppe Corbelli)
  new:
  - cue2toc: convert CUE to TOC format for audio CDs. (Matthias Czapla)
  <snip>

  Note:	The 1.1.8 tarball was re-rolled twice because of missing files and
	a show-stopper in gcdmaster and some SourceForge mirrors still might
	need to catch up on it. If you have problems with differing checksums
	please fetch from ftp://us.dl.sourceforge.net/pub/sourceforge/cdrdao,
	which is known to carry the latest version.
- Use/respect DATADIR and DOCSDIR.
- Make PREFIX-clean by respecting PREFIX instead of LOCALBASE.
- First part of splitting gcdmaster into a slave port because the conditional
  compilation via HAVE_GNOME caused problems when gnomelibs where installed
  afterwards (PR 61840).
- Tidy the PORTDOCS a bit, e.g. no longer install the release notes for
  previous releases, they are easily accessible on the homepage anyway.
- On deinstall, remind the user to delete the global config file if existent
  and permanently removing this port.
- In pkg-descr, mention that cdrdao also handles the bin/cue format. Wording
  taken from the Debian cdrdao package.
- Fix some references in the cdrdao manpage to fit FreeBSD.
- Remove the WITH_PTHREADS knob, it was never very usefull on FreeBSD.
- Remove the WITHOUT_SCGLIB knob, the "native" CAM interface of cdrdao has
  issues with ATAPICAM and probably will be removed in future version.
- Remove "-DBSD_SCSI_SENSE_BUG" from CFLAGS, for an explanation see
  sysutils/sformat/Makefile revision 1.5.

Submitted by:	maintainer
2004-02-18 14:56:10 +00:00

31 lines
936 B
Text

--- scsilib/RULES/i386-freebsd-cc.rul.orig Tue Oct 15 22:43:39 2002
+++ scsilib/RULES/i386-freebsd-cc.rul Sun Oct 27 19:59:00 2002
@@ -24,7 +24,8 @@
###########################################################################
CPPFLAGS= $(CPPOPTS) $(CPPOPTX)
-CFLAGS= $(COPTS) $(CWARNOPTS) $(COPTOPT) $(GCCOPTOPT) $(COPTX)
+XCFLAGS:= $(CFLAGS)
+CFLAGS= $(COPTS) $(CWARNOPTS) $(XCFLAGS) $(GCCOPTOPT) $(COPTX)
CPPOPTS= -I. -I$(ARCHDIR) -I$(OINCSDIR) $(INCDIRS:%=-I%) $(OSDEFS)
COPTS=
@@ -57,14 +58,13 @@
FLOAT_OPTIONS=
-CC= @echo " ==> COMPILING \"$@\""; gcc
-LDCC= @echo " ==> LINKING \"$@\""; gcc
-DYNLD= @echo " ==> LINKING dynamic library \"$@\""; gcc
-RANLIB= @echo " ==> RANDOMIZING ARCHIVE \"$@\""; ranlib
+LDCC= $(CCOM)
+DYNLD= $(CCOM)
+RANLIB= ranlib
ARFLAGS= cr
LORDER= lorder
TSORT= tsort
RMDEP= :
-MKDEP= @echo " ==> MAKING DEPENDENCIES \"$@\""; $(RMDEP); gcc -M
+MKDEP= $(CCOM) -M
MKDEP_OUT=