87 lines
3.6 KiB
Text
87 lines
3.6 KiB
Text
--- gcc-3.2.3/gcc/Makefile.in.orig Tue Jan 28 16:54:07 2003
|
|
+++ gcc-3.2.3/gcc/Makefile.in Sun Nov 16 21:11:17 2003
|
|
@@ -405,7 +405,7 @@
|
|
|
|
# It is convenient for configure to add the assignment at the beginning,
|
|
# so don't override it here.
|
|
-USE_COLLECT2 = collect2$(exeext)
|
|
+USE_COLLECT2 =
|
|
|
|
# List of extra C and assembler files to add to static and shared libgcc2.
|
|
# Assembler files should have names ending in `.asm'.
|
|
@@ -445,7 +445,7 @@
|
|
|
|
# A list of all the language-specific executables.
|
|
# This is overridden by configure.
|
|
-COMPILERS = cc1$(exeext) @all_compilers@
|
|
+COMPILERS = @all_compilers@
|
|
|
|
# List of things which should already be built whenever we try to use xgcc
|
|
# to compile anything (without linking).
|
|
@@ -2531,9 +2531,8 @@
|
|
# Copy the compiler files into directories where they will be run.
|
|
# Install the driver last so that the window when things are
|
|
# broken is small.
|
|
-install: install-common $(INSTALL_HEADERS) $(INSTALL_LIBGCC) \
|
|
- $(INSTALL_CPP) install-man install-info intl.install install-@POSUB@ \
|
|
- lang.install-normal install-driver
|
|
+install: install-common \
|
|
+ intl.install lang.install-normal
|
|
|
|
# Handle cpp installation.
|
|
install-cpp: cpp$(exeext)
|
|
@@ -2581,54 +2580,6 @@
|
|
else true; \
|
|
fi; \
|
|
done
|
|
- for file in $(EXTRA_PASSES) $(EXTRA_PROGRAMS) $(USE_COLLECT2) ..; do \
|
|
- if [ x"$$file" != x.. ]; then \
|
|
- rm -f $(DESTDIR)$(libsubdir)/$$file; \
|
|
- $(INSTALL_PROGRAM) $$file $(DESTDIR)$(libsubdir)/$$file; \
|
|
- else true; fi; \
|
|
- done
|
|
- for file in $(EXTRA_PARTS) ..; do \
|
|
- if [ x"$$file" != x.. ]; then \
|
|
- rm -f $(DESTDIR)$(libsubdir)/$$file; \
|
|
- $(INSTALL_DATA) $$file $(DESTDIR)$(libsubdir)/$$file; \
|
|
- chmod a-x $(DESTDIR)$(libsubdir)/$$file; \
|
|
- else true; fi; \
|
|
- done
|
|
-# Don't mess with specs if it doesn't exist yet.
|
|
- -if [ -f specs ] ; then \
|
|
- rm -f $(DESTDIR)$(libsubdir)/specs; \
|
|
- $(INSTALL_DATA) specs $(DESTDIR)$(libsubdir)/specs; \
|
|
- chmod a-x $(DESTDIR)$(libsubdir)/specs; \
|
|
- fi
|
|
-# Install protoize if it was compiled.
|
|
- -if [ -f protoize$(exeext) ]; \
|
|
- then \
|
|
- if [ -f gcc-cross$(exeext) ] ; then \
|
|
- rm -f $(DESTDIR)$(bindir)/$(PROTOIZE_CROSS_NAME)$(exeext); \
|
|
- $(INSTALL_PROGRAM) protoize$(exeext) $(DESTDIR)$(bindir)/$(PROTOIZE_CROSS_NAME)$(exeext); \
|
|
- rm -f $(DESTDIR)$(bindir)/$(UNPROTOIZE_CROSS_NAME)$(exeext); \
|
|
- $(INSTALL_PROGRAM) unprotoize$(exeext) $(DESTDIR)$(bindir)/$(UNPROTOIZE_CROSS_NAME)$(exeext); \
|
|
- else \
|
|
- rm -f $(DESTDIR)$(bindir)/$(PROTOIZE_INSTALL_NAME)$(exeext); \
|
|
- $(INSTALL_PROGRAM) protoize$(exeext) $(DESTDIR)$(bindir)/$(PROTOIZE_INSTALL_NAME)$(exeext); \
|
|
- rm -f $(DESTDIR)$(bindir)/$(UNPROTOIZE_INSTALL_NAME)$(exeext); \
|
|
- $(INSTALL_PROGRAM) unprotoize$(exeext) $(DESTDIR)$(bindir)/$(UNPROTOIZE_INSTALL_NAME)$(exeext); \
|
|
- fi ; \
|
|
- rm -f $(DESTDIR)$(libsubdir)/SYSCALLS.c.X; \
|
|
- $(INSTALL_DATA) SYSCALLS.c.X $(DESTDIR)$(libsubdir)/SYSCALLS.c.X; \
|
|
- chmod a-x $(DESTDIR)$(libsubdir)/SYSCALLS.c.X; \
|
|
- fi
|
|
- -rm -f $(DESTDIR)$(libsubdir)/cpp0$(exeext)
|
|
- $(INSTALL_PROGRAM) cpp0$(exeext) $(DESTDIR)$(libsubdir)/cpp0$(exeext)
|
|
- -rm -f $(DESTDIR)$(libsubdir)/tradcpp0$(exeext)
|
|
- $(INSTALL_PROGRAM) tradcpp0$(exeext) $(DESTDIR)$(libsubdir)/tradcpp0$(exeext)
|
|
-# Install gcov if it was compiled.
|
|
- -if [ -f gcov$(exeext) ]; \
|
|
- then \
|
|
- rm -f $(DESTDIR)$(bindir)/gcov$(exeext); \
|
|
- $(INSTALL_PROGRAM) gcov$(exeext) $(DESTDIR)$(bindir)/$(GCOV_INSTALL_NAME)$(exeext); \
|
|
- fi
|
|
- $(INSTALL_SCRIPT) gccbug $(DESTDIR)$(bindir)/$(GCCBUG_INSTALL_NAME)
|
|
|
|
# Install the driver program as $(target_alias)-gcc
|
|
# and also as either gcc (if native) or $(gcc_tooldir)/bin/gcc.
|