Firebird is a relational database offering many ANSI SQL-99 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used in production systems, under a variety of names since 1981. Firebird is completely free of any registration, licensing or deployment fees. It may be deployed freely for use with any third-party software, whether commercial or not. WWW: https://sourceforge.net/projects/firebird/ WWW: http://www.firebirdsql.org/ PR: 254387
24 lines
731 B
Text
24 lines
731 B
Text
--- extern/cloop/Makefile 2020-10-12 00:02:22 UTC
|
|
+++ extern/cloop/Makefile
|
|
@@ -6,7 +6,7 @@ TARGET := release
|
|
|
|
CC := $(CC)
|
|
CXX := $(CXX)
|
|
-LD := $(CXX)
|
|
+LD := $(CXX) $(LDFLAGS)
|
|
|
|
SRC_DIR := src
|
|
BUILD_DIR := build
|
|
@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$
|
|
OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
|
|
OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
|
|
|
|
-C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
|
|
-CXX_FLAGS := $(C_FLAGS)
|
|
+COMMON_C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
|
|
+C_FLAGS := $(COMMON_C_FLAGS) $(CFLAGS) $(CPPFLAGS)
|
|
+CXX_FLAGS := $(COMMON_C_FLAGS) $(CXXFLAGS) $(CPPFLAGS)
|
|
FPC_FLAGS := -Mdelphi
|
|
|
|
ifeq ($(TARGET),release)
|
|
|